Salt is available in the FreeBSD ports tree at sysutils/py-salt.
For Python 2.7 use:
Install Salt via the official package repository. Salt is packaged both as a Python 2.7 or 3.7 version.
pkg install py27-salt
For Python 3.7 use:
pkg install py37-salt
Installation from ports:
cd /usr/ports/sysutils/py-salt
make install
Python 3.7 can be used by setting default Python version to 3.7:
echo "DEFAULT_VERSIONS+= python=3.7" >> /etc/make.conf
rc.conf
Activate the Salt Master in /etc/rc.conf
:
sysrc salt_master_enable="YES"
Start the Master
Start the Salt Master as follows:
service salt_master start
rc.conf
Activate the Salt Minion in /etc/rc.conf
:
sysrc salt_minion_enable="YES"
Start the Minion
Start the Salt Minion as follows:
service salt_minion start
Now go to the Configuring Salt page.